NFS deathlock with last Ubuntu Kernel
Incident Report for plusserver
Resolved
Dear Sir or Madam,

in the meantime a fix for the kernel bug has been published.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/2009325

We have re-enabled the patching schedules for Ubuntu systems.

##########

Sehr geehrte Damen und Herren,

mittlerweile wurde ein Fix den Kernelbug veröffentlicht.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/2009325

Wir haben die Patching-Schedules für Ubuntu-Systeme wieder aktiviert.
Posted Mar 30, 2023 - 09:27 CEST
Identified
Dear Sir or Madam,

we are currently facing a bug in the kernel versions 5.4.0-144.161 and 5.15.0-67.74 for the operating systems Ubuntu 18/20/22. This bug currently causes deathlocks to occur on NFS mounts and this causes an increased server load or even a failure/unavailability of the content located on the NFS.
https://www.mail-archive.com/kernel-packages@lists.launchpad.net/msg498932.html

For this reason, we will stop automated patching for Ubuntu until a fix for the kernel is released.

##########

Sehr geehrte Damen und Herren,

zur Zeit gibt es einen Bug in den Kernelversionen 5.4.0-144.161 und 5.15.0-67.74 für die Betriebssysteme Ubuntu 18/20/22. Dieser Bug führt aktuell dazu, dass Deathlocks bei NFS-Mounts auftreten und diese für eine erhöhte Serverlast oder gar einen Ausfall/eine Nichtverfügbarkeit der auf dem NFS liegenden Inhalte sorgt.
https://www.mail-archive.com/kernel-packages@lists.launchpad.net/msg498932.html

Aus diesem Grund werden wir das automatisierte Patching für Ubuntu bis zum Release eines Fix für die Kernel stoppen.
Posted Mar 22, 2023 - 11:08 CET
This incident affected: General.